Laravel Composer提示the requested PHP extension xxx is missing from your system.错误的解决办法

释放双眼,带上耳机,听听看~!

在使用composer更新laravel的依赖时,遇到错误:

  phpoffice/phpspreadsheet 1.14.0 requires ext-fileinfo * ->   the requested PHP extension fileinfo is missing from your system.

错误信息的重点在后半句,意思是我的系统没有开启php fileinfo扩展。

我使用的是宝塔面板,开始php fileinfo扩展很方便,具体步骤如下:

在“软件商店”中找到要开启扩展的php版本,然后点击“设置”,在打开的窗口中选择“安装扩展”,然后找到“fileinfo”,点击“安装”即可,安装成功后,重启一下php就不会再提示错误了。

给TA买糖
共{{data.count}}人
人已赞赏
教程

Laravel Passport提示Class ‘AppProvidersPassport’ not found错误的解决办法

2020-9-25 17:53:45

教程

问道手游-MT3换皮梦幻充值语句

2020-9-29 0:48:42

0 条回复 A文章作者 M管理员
    暂无讨论,说说你的看法吧
个人中心
购物车
优惠劵
今日签到
有新私信 私信列表
搜索